Go Back   Free Software Forum > Emerald Membership of Free Software Forum > Support/Sales Forum

Reply
 
Thread Tools Display Modes

Join Date: Apr 2011
Location: Ireland
Posts: 10

martin is offline martin
Junior Member

  #1  
Old 05-16-2011, 11:52 PM

Default problem with the sending of the sequential auto responder messages.

Hi Dr Quek,

I would appreciate your help with the following.

I have a problem with the triggering of the sequential auto responder messages.

Everything is working as it should but the test emails that I have setup in a sequence are not triggered by the cron. The cron runs every 15 minutes and seems to be working correctly.

I have made the changes to the 'startercron' as follows:

-------------------------------------------------------------

Put here absolute to your broadcaster directory $yourdir='/home/martin/public_html/cgi-bin/ar/';
#You can run this script from cron like
#*/15 * * * * /usr/bin/perl /home/martin/public_html/cgi-bin/ar/cron/startercron
#in this case script will starts each 15 minutes
chdir($yourdir) || die "Can not change dir to $yourdir : $!";
exec('/usr/bin/perl broadcaster');

-------------------------------------------------------------


I would appreciate it if you could provide some further assistance or instructions on setting up the sequential auto responder sequence. I have read the updated manual and visited the forum but can't find a solution to my problem.

All the settings for the messages are set correctly. However if I manually broadcast a message the sequential auto responder messages are also sent.



See screen images attached for further settings.

I look forward to your reply and assistance.

Warm regards,

Martin Kiely.
Reply With Quote

Join Date: Sep 2007
Location: FL, USA
Posts: 1,759

Send a message via ICQ to drquek Send a message via MSN to drquek Send a message via Yahoo to drquek Send a message via Skype™ to drquek
drquek's Avatar
drquek is offline drquek
Administrator

  #2  
Old 05-18-2011, 01:14 AM

Default

Since you post in this forum, I have no idea whether you are a Pro or Lite user. Appreciate if you can submit a help desk ticket or PM me with your registration.
__________________
You can download lots of powerful free software at our Gold Membership Forum.
Click Here to sign up as a Gold Member for free.
Note: You are automatically a Gold Member if you are a member of ANY of our forums.
Reply With Quote

Join Date: Apr 2011
Location: Ireland
Posts: 10

martin is offline martin
Junior Member

  #3  
Old 05-18-2011, 05:40 PM

Default

Hi Dr. Quek,

I am a AMLM/FMLP Pro user.

Reg Code:

I am still experiencing a problem in setting up the email auto responder sequence. Every other function is working correctly except for the auto responder. It may be a setting that I am overlooking and would appreciate your assistance if you could provide some further instructions on the settings for the auto responder sequence.

Thank you. I look forward to your reply.

Martin Kiely.

Last edited by martin; 05-19-2011 at 12:42 PM.. Reason: Removing Reg Code over 24 hours waiting for reply
Reply With Quote

Join Date: Apr 2011
Location: Ireland
Posts: 10

martin is offline martin
Junior Member

  #4  
Old 05-19-2011, 12:59 PM

Default

Hi Dr. Quek,

I am a AMLM/FMLP Pro user.

I have tested all AMLM/FMLP Pro functions and all are working correctly except for the email auto responder sequence.

I am still experiencing a problem in setting up the email auto responder sequence to send messages. I have checked the cron job on my server and it is operating. Messages are sent every 15 minutes to an email account to verify.

It may be a setting that I am overlooking and would appreciate your assistance if you could provide some further instructions or video showing the specific settings of an actual Sequential Autoresponder Sequence that is working correctly.



Thank you. I look forward to your reply.

Martin Kiely.
Reply With Quote

Join Date: Sep 2007
Location: FL, USA
Posts: 1,759

Send a message via ICQ to drquek Send a message via MSN to drquek Send a message via Yahoo to drquek Send a message via Skype™ to drquek
drquek's Avatar
drquek is offline drquek
Administrator

  #5  
Old 05-19-2011, 10:08 PM

Default

If you can send out test messages, it means your sendmail function is working. The other thing you need to check is your cron setting. Your cron setting seem ok. Please check with your host to see if the cron is working properly.
__________________
You can download lots of powerful free software at our Gold Membership Forum.
Click Here to sign up as a Gold Member for free.
Note: You are automatically a Gold Member if you are a member of ANY of our forums.
Reply With Quote

Join Date: Apr 2011
Location: Ireland
Posts: 10

martin is offline martin
Junior Member

  #6  
Old 05-22-2011, 04:34 AM

Default

Hi Dr Quek,

I would appreciate it if you would provide some further text instructions, video or screen images showing the specific settings of an actual working Sequential Autoresponder Sequence.

1. I would like to see a screen shot of your cron settings in your hosting account.
2. I would like to see a screen shot of the changes made to the 'stratercron' file.

I have a Hostgater hosting account. I believe my problem is in getting the cron to start the autoresponder messages.

Please provide some images of a working example so that I can compare and determine what I am doing wrong. This would be a greater help to me in solving the problem.

Thank you in advance for your assistance.

I look forward to your reply.

Martin Kiely.
Reply With Quote

Join Date: Sep 2007
Location: FL, USA
Posts: 1,759

Send a message via ICQ to drquek Send a message via MSN to drquek Send a message via Yahoo to drquek Send a message via Skype™ to drquek
drquek's Avatar
drquek is offline drquek
Administrator

  #7  
Old 05-22-2011, 08:23 PM

Default

For security reason, I can't show you the screen capture. Instead I can show you the text below. This is actually given in the Readme file.


1. cron settings in your hosting account.


/usr/bin/perl /home/abcde/public_html/cgi-bin/amlm/cron/startercron


2. 'stratercron' file.

#Put here absolute to your broadcaster directory
$yourdir='/home/abcde/public_html/cgi-bin/amlm/';

#You can run this script from cron like
#*/15 * * * * /usr/bin/perl /home/abcde/public_html/cgi-bin/amlm/cron/startercron
#in this case script will starts each 15 minutes
chdir($yourdir) || die "Can not change dir to $yourdir : $!";
exec('/usr/bin/perl broadcaster');
__________________
You can download lots of powerful free software at our Gold Membership Forum.
Click Here to sign up as a Gold Member for free.
Note: You are automatically a Gold Member if you are a member of ANY of our forums.
Reply With Quote

Join Date: Apr 2011
Location: Ireland
Posts: 10

martin is offline martin
Junior Member

  #8  
Old 05-31-2011, 11:23 AM

Default

Hi Dr Quek,

Thank you for your reply.

I have made the exact changes as recommended in your last post.

Also I have contacted my Hosting provider and they have assured me that the cron is working correctly.

After making the exact changes as suggested I have setup 3 Autoresponder messages to be delivered automatically 1 day, 2 days and 3 days after registering to my test list.

I am still experiencing the same problem with the Sequential Autoresponder messages not being delivered.

However I have noticed that if I send a manual broadcast the next message in the Autoresponder sequence is also delivered with the manual message!

I would appreciate it if you could arrange a convenient time for a Skype call so that this problem can be resolved. Thank you.

I look forward to your reply.

Regards,

Martin Kiely
Reply With Quote

Join Date: Apr 2011
Location: Ireland
Posts: 10

martin is offline martin
Junior Member

  #9  
Old 06-16-2011, 12:48 PM

Default

Quote:
Originally Posted by martin View Post
Hi Dr Quek,

Thank you for your reply.

I have made the exact changes as recommended in your last post.

Also I have contacted my Hosting provider and they have assured me that the cron is working correctly.

After making the exact changes as suggested I have setup 3 Autoresponder messages to be delivered automatically 1 day, 2 days and 3 days after registering to my test list.

I am still experiencing the same problem with the Sequential Autoresponder messages not being delivered.

However I have noticed that if I send a manual broadcast the next message in the Autoresponder sequence is also delivered with the manual message!

I would appreciate it if you could arrange a convenient time for a Skype call so that this problem can be resolved. Thank you.

I look forward to your reply.

Regards,

Martin Kiely
Hi Dr. Quek,

Just to update you on the Autoresponder software problem.

The good news is that the problem has now been resolved.

I had to wait a few days to make sure that the sequential emails
went through there cycle. Everything is now working as it should.

The problem had to do with some issue with copying and pasting
the code in the Startercron file and in the setting up of the cron
command on my server.

Instead of copying and pasting I would recommend that the change of
code and the setting up of the cron command be done manually.

When I went over the installation of the program the only difference
was the manually typing of each character rather than copying code
and pasting it.

This solved the problem.

Daniel thank you for your help and assistance. I'm sure that this fix
may be helpful to others who may encounter a similar problem.

Regards,

Martin Kiely.
Reply With Quote

Join Date: Sep 2007
Location: FL, USA
Posts: 1,759

Send a message via ICQ to drquek Send a message via MSN to drquek Send a message via Yahoo to drquek Send a message via Skype™ to drquek
drquek's Avatar
drquek is offline drquek
Administrator

  #10  
Old 07-13-2011, 02:33 AM

Default

If you use the automatic installation feature for cron when setting up, I believe you will not face this problem.
__________________
You can download lots of powerful free software at our Gold Membership Forum.
Click Here to sign up as a Gold Member for free.
Note: You are automatically a Gold Member if you are a member of ANY of our forums.
Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -8. The time now is 10:34 AM.


Design By: Miner Skinz.com
Powered by vBulletin® Version 3.8.3
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
2006-2010 Dr. Quek & Associates